Telephone provider outage
Incident Report for WebUX (SiteSuite)
Resolved
Incident resolved and telephone services are back to normal.
Posted Jul 27, 2022 - 16:10 AEST
Investigating
Awaiting a fix to be implemented from our service provider
Posted Jul 27, 2022 - 14:53 AEST
This incident affected: Telephone Support.