Emails Bouncing
Incident Report for WebUX (SiteSuite)
Resolved
This incident has been resolved. Emails are no longer bouncing back to their authors.
Posted Nov 10, 2022 - 13:14 AEDT
Investigating
We are currently investigating the issue and hope to resolve shortly
Posted Nov 10, 2022 - 12:28 AEDT
This incident affected: SiteSuite Hosted Email.