Email bouncing continuing...
Incident Report for WebUX (SiteSuite)
Resolved
This incident has been resolved.
Posted Nov 10, 2022 - 18:37 AEDT
Identified
SiteSuite hosted email customers are continuing to experience bounce backs when sending emails. We are continuing to resolve the issue and apologise for the inconvenience this is causing.
Posted Nov 10, 2022 - 15:48 AEDT
This incident affected: SiteSuite Hosted Email.