Email SPAM event. Issue is being addressed
Incident Report for WebUX (SiteSuite)
Resolved
This incident has been resolved
Posted Sep 12, 2023 - 09:19 AEST
Investigating
We are currently investigating this issue.
Posted Sep 11, 2023 - 13:46 AEST
This incident affected: SiteSuite Hosted Email and SiteSuite Webmail.