E-mail is currently unavailable. Techs are looking into it
Incident Report for WebUX (SiteSuite)
Resolved
The incident has been resolved. Email may take some time to arrive due to backlog.
Posted May 08, 2023 - 10:02 AEST
Investigating
We are currently investigation the issue.
Posted May 08, 2023 - 09:47 AEST
This incident affected: SiteSuite Hosted Email and SiteSuite Webmail.